FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

4167 questions

4739 answers

3460 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
166 views
in Vehicle tracking by anonymous

Hi I've got an FMC640, and received a link to the updates from my sales assistant.

It currently has a firmware version of 00.03.74.T112

When I try and update with either of the two available updates, it always fails:

  • I power the device and plug it in via USB to my computer
  • I open the configurator app that came with the update
  • I select "Update Firmware" and choose the appropriate update. 
  • I have tried both FMB640.Ver.01.00.13.e and FMX64.Ver.01.02.22.Rev.04_ID1.e using the respective configurator app that came with each.
  • The software says it's doing preparing the firmware update.
  • It then gives an error "Failed to update" or similar and disconnects from the computer.
  • The device has a fast blinking light on it, that doesn't stop until I unplug it from power and plug it back in.
  • I tried resetting the configuration before updating.

Any advice to help? Do I need to update to an intermediate version first maybe?

I also have an FMC125 and that updated as expected.

1 Answer

+1 vote
by anonymous

Hello

We would like to analyze your case, therefore please open ticket in VIP Helpdesk and provide all needed information: device IMEI, firmware version, configuration file. If you don't have VIP Helpdesk login. please contact with your Sales Manager. If you don't have any contacts with our Sale managers, please contact with them on our official website https://teltonika-gps.com/ and click on the "Contact Us" button. When you will click, please fill the form and submit it. Note: as a topic, please choose "Vehicle telematics".
Or you can send an e-mail with description of your situation to info@teltonika.lt

Best Regards