FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE
Ask a question

3952 questions

4498 answers

3319 comments

50490 members

Ask a question
0 votes
1,894 views
in Vehicle tracking by
Our FMB001 devices are not sending CAN and OBD data.  I have enabled OBD in the configurator, but its not coming through.  please assist

2 Answers

0 votes
by
Hello,

In Systems menu set Data Protocol to Codec 8 extended .

In OBDII menu set priority  to at least LOW in order to receive data on your server.

Thanks
Best answer
by
Hi.

This still doesn't work.  Please advise
0 votes
by

Hello,

Thank you for your question,

Please make sure that your vehicle supports one of the OBDII protocols:

  1. SAE J1850 PWM (41.6 kbaud);
  2. SAE J1850 VPW (10.4 kbaud);
  3. ISO 9141-2 (5 baud init, 10.4 kbaud);
  4. ISO 14230-4 KWP (5 baud init, 10.4 kbaud);
  5. ISO 14230-4 KWP (fast init, 10.4 kbaud);
  6. 15765-4 CAN (11 bit ID, 500 kbaud);
  7. ISO 15765-4 CAN (29 bit ID, 500 kbaud);
  8. ISO 15765-4 CAN (11 bit ID, 250 kbaud);
  9. ISO 15765-4 CAN (29 bit ID, 250 kbaud).

Also check if the OBDII is received by using SMS command "obdinfo", more info of the SMS commands can be found in our wiki link:

https://wiki.teltonika.lt/view/FMB_SMS/GPRS_Commands

The description on command "obdinfo" can be found here:

https://wiki.teltonika.lt/view/FMB_obdinfo

Use the response and a tool to check out the available data from your vehicle:

https://wiki.teltonika.lt/view/How_to_check_available_OBDII_data%3F

In case this does not help, contact your sales manager to receive the newest version of firmware, that has multiple fixes for OBDII devices.

Regards, Teltonika

by
Hi.

Response from sending obdinfo:

Prot:0,VIN:N/A,TM:10,CNT:0,ST:PROT DETECT,P1:0x0,P2:0x0,P3:0x0,P4:0x0,MIL:0,DTC:0,ID3,Hdr:0,Phy:0

Not entirely sure what to make of this?

EDIT:  the unit did send data before, but then i changed tracking service providers and it now doesn't supply any information

Regards

Geoffrey
by
Hi.  Please see response above and advise
by
Hi,

Please, provide the used FW version and "obdinfo1" response. Seems FW must be updated to solve OBDII communication issues.
by
Hi, this is the response from " obdinfo1"  P1:0x0,P2:0x0,P3:0x0,P4:0x0,C1:0x0,C2:0x0,C3:0x0,C4:0x0,Hdr:0,Phy:0,CFG:0,v100.602.100

How do I get the latest firmware?
by

Seems you are using 03.18.xx. You can try FW posted in this thread. Or contact your sales manager to get the >= 03.25.05 version. Configurator is available from here.