FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

4167 questions

4739 answers

3460 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
554 views
in Vehicle tracking by anonymous
Hi,
I would like to get all messages from the FMM130 together with the SIM ICCID - so that I can correlate this with connectivity data.
I see the parameters 50250, 50251 and 50254 https://wiki.teltonika-gps.com/view/FMM130_Parameter_list#Parameters - but I am unsure what is the right setting of these parameters to get the ICCID with every message.
Thanks

1 Answer

0 votes
by anonymous

Hello,

You can set the ICCID I/O Element to Low/High priority via the configurator in order to get the data packets from the device with ICCID.

The following parameter IDs 50250, 50251, and 50254 represent another alternative way to set ICCID I/O element parameters via the SMS/GPRS command 'setparam'. 50250 (ICCID Priority), 50251 (ICCID Operand), and 50254 (ICCID Event only).

For example, to set the ICCID I/O Element to Low priority you can send the following SMS/GPRS Command :

  • '  setparam 50250:1' (if you are not using SMS login).
  • 'login password setparam 50250:1' (if you are using SMS login).

Hope this answers your question.

Kind regards.

by anonymous

I had tried setparam 50250:1 already before but it is not adding the ICCIDs to the message. I now also restarted device and also tried all the other options for 50251 and 50254. I only get the ICCID when directly requesting it via the getimeiccid command.

So this behavior is then unexpected / bug? 

 

by anonymous

Could you send the following SMS/GPRS command and provide me with the response:

  • '  getparam 50250;50251;50254' (if you are not using SMS login)
  • 'login password getparam 50250;50251;50254' (if you are using SMS login)
by anonymous

This is the output from flespi

{
  "timestamp": 1646645216,
  "response": "Param ID:50250 Value:1",
  "id": 1646645215655316,
  "position": 1,
  "name": "getparam",
  "device_id": 2739437,
  "executed": true,
  "properties": {
    "param": 50250
  },
  "expires": 0
}
{
  "timestamp": 1646645322,
  "response": "Param ID:50251 Value:2",
  "id": 1646645320626849,
  "position": 1,
  "name": "getparam",
  "device_id": 2739437,
  "executed": true,
  "properties": {
    "param": 50251
  },
  "expires": 0
}




{ "timestamp": 1646645353, "response": "Param ID:50254 Value:1", "id": 1646645353070238, "position": 1, "name": "getparam", "device_id": 2739437, "executed": true, "properties": { "param": 50254 }, "expires": 0 }
by anonymous

The problem seems to be with the set parameter values.

  • Operand (Param ID:50251) should be "Monitoring" (Value:3) instead of "On both" (Value:2).
  • Event only (Param ID:50254) should be set to "NO" (Value:0) instead of "YES" (Value:1).

You can send the following SMS command which will fix these issues:

  • '  setparam 50251:3;50254:0' (if you are not using SMS login)
  • 'login pass setparam 50251:3;50254:0' (if you are using SMS login)