FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE
Ask a question

3844 questions

4379 answers

3252 comments

46074 members

Ask a question
0 votes
631 views
in Vehicle tracking by
Hello,

Today, I have just purchase FMB001, why it does not send VIN?, I have tried it to 2 cars. (Suzuki Baleno 2017 and Toyota Innova 2019)

Please help

Thanks a lot in advance

Regards

don

1 Answer

0 votes
by
Hello.

First make sure that your vehicle can give out this parameter.

Here is guide how to do it: https://wiki.teltonika-gps.com/view/How_to_check_available_OBDII_data%3F

If you have anymore questions please ask.

Best Regards
by
by
Hello.

I am sorry, but in this case pretty much no parameters can be read from this car including VIN.

Best Regards
by
I have tried to plug it into another car (Toyota Innova 2017) and now .. it returns like below:

Prot:6,VIN:MHFJW8EM9H2335114,TM:20,CNT:18,ST:DATA REQUESTING,P1:0xBE1FA813,P2:0x9005B015,P3:0x7ADC8001,P4:0x10000000,MIL:0,DTC:0,ID3,Hdr:7E8,Phy:1

but why the VIN (io256) does not sent to my traccar? .. I configured OBD II -> VIN to High Priority and Monitoring..

what I missed?

please help
by
Hello.

Could you attach your configuration file?

What firmware version are you using?

Best Regards
by

Here is the config file:

Config File

Firmware version 03.25.05 Rev:00

by
Hi,

I can see the problem - your "Data protocol" parameter in "System" tab is selected as Codec 8. You have to select "Codec 8 Extended", since the VIN I/O element ID is bigger than 255 (Regular Codec 8 only uses 1 byte for storing I/O ID when sending to server, so due to this, it skips the elements that have a bigger ID than 255 in the record).

Let me know if this helps.
by
Yes it works. Thanks a lot