subscribe to our Youtube


4167 questions

4739 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
+1 vote
in Vehicle tracking by

I am working for a few days on getting FM3001 data to a server. The device is connecting to the server, but it does not send any TCP data (such as an IMEI). Could this be a setting in the FM3001 I missed? I also did some TCPdump/Wireshark traces on the server:

16:29:00.183035 IP > domain.4554: Flags [.], ack 1, win 16384, length 0
16:30:58.428359 IP > domain.4554: Flags [S], seq 1706201088, win 16384, options [mss 1460,wscale 0,eol], length 0

Somebody an idea what could be wrong? Could it be a setting or firmware?

5 Answers

0 votes
Hi, Krijn Tanis.

You can get logs from device (use either Hercules and USB or SMS-command log2srv) and post it here.
Thank you for your quick reply! Just tried to enable log2srv, but does not seems to work (I do not get a SMS reply). When I try getgps or getver, I do get a reply.

Just connected it using USB and I got error log. Can't see anything strange there:

[2019.12.11 13:38:38]-[WD.FUNC]	WARNING @ 172:counter:2 Cnt:4781 Limit:10800
[2019.12.11 13:38:42]-[REC.SEND.1]	Mode: 0/Home on Stop. Time for next periodic data sending: 104 / 120
[2019.12.11 13:38:45]-[BLE.APP]	bt init: 1, ble init: 1, sens en: 0, cnt: 0/120, listen: 1, broadcast: 0/0x0000
[2019.12.11 13:38:45]-[BLE.APP]	[00] connected: 0, target addr: 00:00:00:00:00:00
[2019.12.11 13:38:45]-[BLE.APP]	[01] connected: 0, target addr: 00:00:00:00:00:00
[2019.12.11 13:38:45]-[BLE.APP]	[02] connected: 0, target addr: 00:00:00:00:00:00
[2019.12.11 13:38:45]-[BLE.APP]	[03] connected: 0, target addr: 00:00:00:00:00:00
[2019.12.11 13:38:45]-[BLE.APP]	ble scan status: 0, caller status: 0/?, unlimited: 0
[2019.12.11 13:38:48]-[OVERSPD]	Scenario disabled!
[2019.12.11 13:38:48]-[SLEEP]	Sleep:0, not allowed! Reason:Disabled by CFG
[2019.12.11 13:38:48]-[WD.FUNC]	WARNING @ 172:counter:2 Cnt:4791 Limit:10800
[2019.12.11 13:38:52]-[REC.SEND.1]	Mode: 0/Home on Stop. Time for next periodic data sending: 114 / 120
[2019.12.11 13:38:58]-[OVERSPD]	Scenario disabled!
[2019.12.11 13:38:58]-[REC.SEND.1]	Mode: 0/Home on Stop. Period: 120. Starting periodic data sending
[2019.12.11 13:38:58]-[REC.SEND.1]	Caller: 1139, queueing recsend1 task job type: 0/records
[2019.12.11 13:38:58]-[SLEEP]	Sleep:0, not allowed! Reason:Disabled by CFG
[2019.12.11 13:38:58]-[LiPo]	cant en charger; Vext: 0, Vbat: 1, first charger: 0, addon: 1, dsleep: 1
[2019.12.11 13:38:58]-[LiPo]	BatState: 1 FSMState: ACTIVE ChargerIC: OFF ExtV: 750 BatV: 3809 BatI: 0
[2019.12.11 13:38:58]-[LiPo]	WARNING @ 1034:Unknown charger type!
[2019.12.11 13:38:58]-[WD.FUNC]	WARNING @ 172:counter:2 Cnt:4801 Limit:10800
[2019.12.11 13:38:59]-[REC.SEND.1]	[CHANGE.STATE.0163] Server: 0, finished => check rec no
[2019.12.11 13:38:59]-[REC.SEND.1]	check rec no
[2019.12.11 13:38:59]-[REC.GEN]	Server: 0, not all min records send: 1/1
[2019.12.11 13:38:59]-[CODEC.APP]	Rec found at 0x00000000, sort:1
[2019.12.11 13:38:59]-[REC.SEND.1]	Have enough records to send!
[2019.12.11 13:38:59]-[REC.SEND.1]	[CHANGE.STATE.0260] Server: 0, check rec no => check gprs
[2019.12.11 13:38:59]-[REC.SEND.1]	check gprs
[2019.12.11 13:38:59]-[REC.SEND.1]	gprs is open
[2019.12.11 13:38:59]-[REC.SEND.1]	gprs settings the same -> check link
[2019.12.11 13:38:59]-[REC.SEND.1]	[CHANGE.STATE.0300] Server: 0, check gprs => check link
[2019.12.11 13:38:59]-[REC.SEND.1]	check link
[2019.12.11 13:38:59]-[REC.SEND.1]	link is closed, try to open
[2019.12.11 13:38:59]-[NETWORK]	[SOCKET.OPEN.0425] Target:0 Events Cleared
[2019.12.11 13:38:59]-[NETWORK]	[SOCKET.OPEN.0425] IP format x.y.z.q detected, resolving not needed
[2019.12.11 13:38:59]-[NETWORK]	Target IP:<IP-ADDRESS-REMOVED> (valid:1)
[2019.12.11 13:38:59]-[NETWORK]	[SOCKET.OPEN.0425] Socket target: 0, attempt: 1/3
[2019.12.11 13:38:59]-[ATCMD]	<<AT+QICLOSE=0

[2019.12.11 13:38:59]-[MODEM.ACTION]	GSM Update Reason:Periodic
[2019.12.11 13:38:59]-[ATCMD]	>>[170] OK
[2019.12.11 13:38:59]-[ATCMD]	<<AT+CPAS

[2019.12.11 13:38:59]-[ATCMD]	>>[122] +CPAS: 0
[2019.12.11 13:38:59]-[ATCMD]	>>[122] OK
[2019.12.11 13:38:59]-[ATCMD]	<<AT+QIOPEN=1,0,"TCP","<IP-ADDRESS-REMOVED>",4554,0,0

[2019.12.11 13:38:59]-[ATCMD]	>>[169] OK
[2019.12.11 13:38:59]-[NETWORK]	[SOCKET.OPEN.0425] Waiting for create conn result, waiting: 160 sec
[2019.12.11 13:38:59]-[ATCMD]	<<AT+CIMI

[2019.12.11 13:38:59]-[ATCMD]	>>[151] 204163554991368
[2019.12.11 13:38:59]-[ATCMD]	>>[151] OK
[2019.12.11 13:38:59]-[ATCMD]	<<AT+CREG?

[2019.12.11 13:38:59]-[ATCMD]	>>[127] +CREG: 2,1,"5E3","D12359",2
[2019.12.11 13:38:59]-[AT.RSP]	Status: 1
[2019.12.11 13:38:59]-[AT.RSP]	Area Code: 1507
[2019.12.11 13:38:59]-[AT.RSP]	Cell ID: 9049
[2019.12.11 13:38:59]-[AT.RSP]	Registration Mode: 2
[2019.12.11 13:38:59]-[AT.RSP]	Registered To Home Network
[2019.12.11 13:38:59]-[ATCMD]	>>[127] OK
[2019.12.11 13:38:59]-[ATCMD]	<<AT+CSQ

[2019.12.11 13:38:59]-[ATCMD]	>>[121] +CSQ: 8,99
[2019.12.11 13:38:59]-[ATCMD]	>>[121] OK
[2019.12.11 13:38:59]-[ATCMD]	<<AT+CBC

[2019.12.11 13:38:59]-[ATCMD]	>>[126] +CBC: 0,68,3845
[2019.12.11 13:38:59]-[ATCMD]	>>[126] OK
[2019.12.11 13:38:59]-[ATCMD]	<<AT+CFUN?

[2019.12.11 13:38:59]-[ATCMD]	>>[136] +CFUN: 1
[2019.12.11 13:38:59]-[ATCMD]	>>[136] OK
[2019.12.11 13:38:59]-[ATCMD]	<<AT+COPS?

[2019.12.11 13:38:59]-[ATCMD]	>>[123] +COPS: 0,2,"20416",6
[2019.12.11 13:38:59]-[ATCMD]	>>[123] OK
[2019.12.11 13:38:59]-[ATCMD]	<<AT+CMGL=4

[2019.12.11 13:38:59]-[ATCMD]	>>[125] OK
[2019.12.11 13:38:59]-[MOD.TSK]	SMS Read Map:0,0,0,0 Index:32
[2019.12.11 13:38:59]-[MODEM.ACTION]	SMS Not Found
[2019.12.11 13:38:59]-[MODEM.ACTION]	status done
[2019.12.11 13:38:59]-[ATCMD]	>>[176] +QIOPEN: 0,0
[2019.12.11 13:38:59]-[NETWORK]	connection established! acc id: 0, socket id: 0, evt sending: enabled
[2019.12.11 13:38:59]-[NETWORK]	VR socket 0 open! real socket id: 0
[2019.12.11 13:38:59]-[NETWORK]	WARNING @ 2706:[CLEAR.ERROR.CNT.0425] Error count: 1 cleared
[2019.12.11 13:38:59]-[REC.SEND.1]	link timeout reset for server: 0
[2019.12.11 13:38:59]-[REC.SEND.1]	launching link monitoring
[2019.12.11 13:38:59]-[SCH]	Task eM2M_Tid_link_tmo_checking[11] has been scheduled. Period: 1s
[2019.12.11 13:38:59]-[REC.SEND.1]	[CHANGE.STATE.0485] Server: 0, check link => send imei
[2019.12.11 13:38:59]-[REC.SEND.1]	send imei
[2019.12.11 13:38:59]-[ATCMD]	<<AT+QISEND=0,17

[2019.12.11 13:38:59]-[ATCMD]	>>[172] >QIOPEN: 0,0
[2019.12.11 13:38:59]-[ATCMD]	>>[173]  
[2019.12.11 13:38:59]-[ATCMD]	>>[173] SEND OK
[2019.12.11 13:38:59]-[ATCMD]	<<AT+QISEND=0,0

[2019.12.11 13:38:59]-[ATCMD]	>>[172] +QISEND: 17,0,17
[2019.12.11 13:38:59]-[ATCMD]	>>[172] OK
[2019.12.11 13:38:59]-[NETWORK]	[SEND.DATA.0512] Waiting for socket send result, waiting: 10 sec
[2019.12.11 13:38:59]-[REC.SEND.1]	imei send OK, waiting 30 sec for imei answer
[2019.12.11 13:39:00]-[ADC]	Measured Values Table:
	[Core Voltage  ]:		1.000	(3772)	0
	[External V    ]:		16.000	(750)	490
	[Battery V     ]:		1.727	(3797)	0
	[Ch. current   ]:		0.060	(1)	0
	[OBD Periph    ]:		5.085	(11071)	0
	[NTC           ]:		1.000	(2069)	0
	Using Conv Table:FMB0XX CalibVals:1
[2019.12.11 13:39:02]-[REC.SEND.1]	Mode: 0/Home on Stop. Time for next periodic data sending: 4 / 120
[2019.12.11 13:39:08]-[OVERSPD]	Scenario disabled!
[2019.12.11 13:39:08]-[SLEEP]	Sleep:0, not allowed! Reason:Disabled by CFG
[2019.12.11 13:39:08]-[WD.FUNC]	WARNING @ 172:counter:2 Cnt:4811 Limit:10800
[2019.12.11 13:39:10]-[TSYNC]	Time Sync request by NTP DROPED
[2019.12.11 13:39:12]-[REC.SEND.1]	Mode: 0/Home on Stop. Time for next periodic data sending: 14 / 120
[2019.12.11 13:39:15]-[SYS.DIAG]	

Code Version:03.25.05
Code Rev:00
IMEI:	864403044867050
HW ver:	FM3001
HW mod:	1
HW volt:152mV
HW tbl:	1
BL ver:	1.7
BLE:	1

BT ADDR:{53:2E:52:20:62:61}

Started:2019-12-11 12:14
Uptime:	0d 1h 24min 17s
PWR rsn:SoftReset Cnt:0
Mode:Home on Stop

GPS Fix: 0
GPS state: 1
TTFF:	 5s
TTLF:	 0s
NoFix:	 1580s
Latitude :51.<REMOVED>
Altitude :0
FW Ver:	AXN_5.10_3333_17041900,0000,,
0 votes
by anonymous

Can you upload the log for minimum 5 minute, You can use google drive or we transfer.

If you can please upload the configuration file also.

Thanks in advance

0 votes
by anonymous

In the log we can see ,the device is sending IMEI to IP at 4554 port through TCP.

But the server is not sending any acknowledgement to the device, so the device is cancelling the data sending procedure.

You should have an application in the server which can respond to the device data.

If you don't have any application, You can use Hercules tool.



Hi Naveen, thank you for your reply! Yes, we have a server running that will send a binary 01 back. But this application is not receiving any data (also checked with Wireshark). When I test with Hercules tool, I see same results: no data and nothings happens when I send a 01 back to the devices: 

(I tried sending 01 several times). 

0 votes
by anonymous


Did you stop your server application before connecting to Hercules ? Otherwise device will send data to application not to your Hercules  tool.

You configured the same TCP port in Hercules which is 4554 ?

Are you receiving the IMEI from the device in Hercules ? 

Can you please upload the log from the device while it's trying to send data to Hercules .




Hi again,

thanks! Yes, I stopped the server (server is in datacenter) and changed IP and port to my computer public IP and a changed port, see screenshot from configuration manager. I will upload log as well. As you see in my screenshot, the FM3001 IS connecting to Hercules, but not any data is coming (such as an IMEI). 


You have to Tick Hex box in order to send commands 

Yes, but manual says it needs to ben Binary 01. But also when I try it with HEX, it give same problem:

[2019.12.13 14:16:26]-[REC.SEND.1] ERROR @ m2m_task_recsend_1.c(536):No server response: 51 to sent IMEI, rec sending canceled

[2019.12.13 14:16:26]-[REC.SEND.1] [CHANGE.STATE.0537] Server: 0, send imei => finish

I still see in Hercules and in my Wireshark trace, the FM3001 is not sending its IMEI.

0 votes
by anonymous

I can't find anything wrong here. It should receive the data.

You have any firewall and antivirus in the system, Can you please disable both and test.


Hi, there is no virusscanner and no firewall. I see packets coming, but no data is in the packets. I ordered a Teltonika FM001 to see if that works. Maybe the device we got, is broken.


Finally I got it working, problem was the SIM card. No idea why, but it was a data SIM, it connected but no data. Other things were working, so no idea what was wrong in the end.

Thank you Naveen for al you help!