Ask a question

3592 questions

4090 answers

3024 comments

34758 members

Ask a question
0 votes
1,267 views
in Vehicle tracking by
Hello! we are new with Teltonika and we have some trouble with dallas temperature sensor. We use a 8m cable with a tested DS18b20 (works perfect with other tracker with one-wire input) and sometimes the sensor stop reading, or sends error 3000. If we reset the device, or disconnect and connect the sensor, it starts working again.

We need to solve this problem ASAP, or have to choose another gps device.

thank you very much !
by
Which FW version are you having trouble with?
by
Hello, we also have the same problem with the FM3612, the firmware is the latest available on 01.09.22.Rev: 0. Could someone help us?

3 Answers

0 votes
by
01.09.22 rev 0
0 votes
by
Please take log via USB cable using terminal. Log should start when device can read temperature and catch the moment when DS18B20 sensor stops sending data.
0 votes
by
We had the same problem and also if you unplug the device and plug it again it will burn your sensors. This happens because when the device powers up it sends to one wire power for half a sec 12 or 24 v depending on the power supply.

Now for the sensors if you are using 4 dallas make sure the folowing:

1 use 24 volts power supply (beter than 12) minimum 5A

2 Make sure the device has valid GPS signal

3 Use a resistor 2.2 KΩ between one wire power and one wire data (not4.7)

This should solve your problem

Make sure that you will connect a capacitor 100 mf (paralel connection ) between one wire power and GND for protecting the thermometers.

If you still facing any problem please do not hesitate to contuct us in order to help you

Hope it helped