Ask a question

3608 questions

4102 answers

3027 comments

35259 members

Ask a question
0 votes
105 views
in Vehicle tracking by

Good day,

i started working with a FMC640. And already have important questions:

a) the device is not charging even after I increased input voltage to 15V. Please see status picture attached.

 

b) I correctly inserted a 32GB SAMSUNG evo SDcard.

Trying to format the card ends with error. Pls see picture attached.

 

c) where do I get the latest firmware file? Within the download section

https://teltonika-gps.com/product/fmc640/#downloads

I can not find any e.XIM file.

Thanks for your ideas.
Do they have product support? Or only self-support?

Greetings - George
M.A.C.S.tech

1 Answer

0 votes
by
Hello,

a) Please check the device's configuration settings in the "System" tab and check if "On need" option is selected under the "Battery Charge Mode". If it is and the battery is still not charging, then please check the physical connection of the battery unit with the PCB, the unit should be connected with no loose cables. If the issue still persists, please check the battery itself, take photos of the PCB unit - TOP view and BOT(bottom) view, battery and create a query on the VIP Helpdesk regarding the battery not charging.

b) Please check the formatting of the SD card, the required format should be FAT32, if it is, then please try replacing the card with another 16 GB  FAT32 format SD card.

c) Due to security reasons, the firmware versions are available upon request from the sales personel or through VIP Helpdesk query requests. Please contact your sales manager in order to receive the newest available firmware for your FMC640 unit or to get information on how to create a VIP Helpdesk query regarding firmware requests.

Kind regards.
by
a) charging: solved. battery was not connected to pcb.

b) Still same error. Tried new 16GB and 32GB FAT32 and also unformatted.

c) firmware: understodd
by
Hello,

Good to hear that battery issue is fixed, regarding the Micro SD card, I can see that your device is actually able to read the SD card, however the formatting issue is associated with this firmware version. Please try to update the firmware as previously advised by contacting your sales representative and that should help you fix the issue.

Kind regards.
by

Thanks for your support. I have now contacted GETIC SIA as the seller for firmware update. Let's see...

I will sure one day understand the support policy of Teltonik. Are you MindaugasK from Teltonik? Are the products installed/maintained by Teltonik-partners only? If I buy a device with SD card functionality and the SD card is not working due to an firmware issue I might have further questions on the reliability of the product. Anyhow, I am sure before we use this FMC640 in production Teltonik will contact us for possible business in future.

Therefore I close this thread. Still a little disappointed.

Jörg