FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE
Ask a question

3743 questions

4265 answers

3170 comments

41444 members

Ask a question
0 votes
1,902 views
in Vehicle tracking by
Hello!

I have got FMB120 and it works like a charm, but I have FMA 120 also and there is a problem.

FMA120 doesn't send sms - any answer to request send by sms (ggps, getinfo, etc.) and any sms with IO trigger - for example external power.

What's wrong with this tracker?

SIM card from FMB120 so it works well, no PIN, last firmware FMA1YX.01.27.29.Rev.0.e.CFW, FMA_Configurator_v1.1.27.12, GSM>SMS events>Extrenal volltage, SMS number 48666846XXX, I/O- External voltage 11000-15000  as HIGH, on both.

Any ideas? Should I install Terminal?

Regards

1 Answer

+1 vote
by

Hello,

Thank you for your question.

When you connect your FMA120 device to the configurator, is the SimPin status showing up as "working"? Check the image below to see where you can check the SIM status.

If the SimPin status shows up as unspecified, then make sure you have inserted the SIM card correctly. You can find the FMA120 First Start instructions on our wiki page here:

https://wiki.teltonika.lt/view/FMA120_First_Start

If the SimPin status is showing up as working, and the device is still not responding to SMS commands, make sure that you are sending SMS commands in the correct format. The SMS command format looks like this:

  • <SMSlogins><space><SMSpassword><space><SMScommand>

If there is no SMS login and password set, the format looks like this:

  • <space><space><SMScommand>

Other reasons why the device might not respond to SMS commands:

  • Device is in Deep Sleep mode;
  • Device is in a location where there is no GSM signal;
  • The phone number from which commands are being sent is not in the authorized numbers list. Note: Authorized numbers list only takes effect if at least one phone number is entered in the list. If not, any phone number can send SMS commands to the device.
  • The SMS login and password in the SMS command is wrong.

If all of these conditions are not the case, and the device is still not sending SMS responses, then please generate a log file from the device using Terminal  and post it here.

Here is how to do that:

  1. Download Terminal software from http://avl1.teltonika.lt/Downloads/Software/Terminal.zip
  2. Connect the device to the PC using the USB cable and through the device manager find which COM port is the USB Modem port.
  3. Set the settings according to the image:
  4. Enable DTR and RTS (when enabled they light up green)
  5. Press start log and choose a directory where you want the log file to be saved.
  6. Select the COM port that is the USB Modem port.
  7. Press connect. Data should be visible on the main window if everything is set up correctly.
  8. Send a few SMS messages to the device. Send the commands in 1 minute intervals.
  9. After you're done, press disconnect and attach the log files here, and I will inspect them.

Best regards.

Best answer
by

Thank You very much for your support!

In my opinion, in addition to the reliability and capabilities of the tracker, a very important aspect of tracking equipment is technical support, so I choose Teltonika. I saw how the community.teltonika-gps.com works and I know that I made good move.

I did what you said, I used Terminal and in log I noticed the error: “+CMS ERROR: 38”

Google told me it is network problem, and I took it away it can be an SMSC error – incorrect Short Message Service Center’s number.

[SMS.READ] SMSC number:48790998600

As I have checked, the correct Virgin Mobile SMSC number is +48 790 998 622

I put the SIM card to the regular phone and changed it. And now it works!

It's weird because I have 2 Virgin Mobile SIM cards, similar numbers, one batch and have different SMSC’s numbers assigned.

Someone might think that only Japan, China, South Korea and USA count in electronic world. But there is Lithuania yet, and does it very well.

Regards and I wish you more new satisfied customers.

by

I got this problem.