Ask a question

2070 questions

2424 answers

2008 comments

5420 members

Ask a question
0 votes
22 views
ago in Vehicle tracking by

Good day,

I am trying to implement codec 12 to try and poll a device on rs485 using a fmb125 as per this documentation:  
https://wiki.teltonika-gps.com/view/Codec#Codec_12

Now the example message GETINFO is working and replies to me.

I send:
  `000000000000000F0C010500000007676574696E666F0100004312`

and get a response:

HEX:

'{00}{00}{00}{00}{00}{00}{00}{99}{0C}{01}{06}{00}{00}{00}{91}{52}{54}{43}{3A}{32}{30}{32}{31}{2F}{31}{2F}{31}{31}{20}{34}{3A}{35}{20}{49}{6E}{69}{74}{3A}{32}{30}{32}{31}{2F}{31}{2F}{31}{31}{20}{33}{3A}{34}{39}{20}{55}{70}{54}{69}{6D}{65}{3A}{39}{39}{38}{73}{20}{50}{57}{52}{3A}{50}{77}{72}{56}{6F}{6C}{74}{61}{67}{65}{20}{52}{53}{54}{3A}{30}{20}{47}{50}{53}{3A}{33}{20}{53}{41}{54}{3A}{36}{20}{54}{54}{46}{46}{3A}{38}{34}{20}{54}{54}{4C}{46}{3A}{38}{34}{20}{4E}{4F}{47}{50}{53}{3A}{30}{3A}{30}{20}{53}{52}{3A}{30}{20}{46}{47}{3A}{30}{20}{46}{4C}{3A}{30}{20}{53}{4D}{53}{3A}{30}{20}{52}{45}{43}{3A}{36}{20}{4D}{44}{3A}{34}{20}{44}{42}{3A}{30}{01}{00}{00}{68}{EE}'

ASCII:
`{00}{00}{00}{00}{00}{00}{00}™{0C}{01}{06}{00}{00}{00}‘RTC:2021/1/11 4:4 Init:2021/1/11 3:49 UpTime:939s PWR:PwrVoltage RST:0 GPS:3 SAT:6 TTFF:84 TTLF:84 NOGPS:0:0 SR:0 FG:0 FL:0 SMS:0 REC:6 MD:4 DB:0{01}{00}{00})`

Now when I try and send my own custom message (modbus via rs485)

 I send:
'00 00 00 00 00 00 00 10 0C 01 05 00 00 00 08 65 03 00 01 00 08 1D E8 01 00 00 DA 8B'

I then see my device flash (it gets the message and responds). 

However I do not get any message or response back on the server, I can even try writing to the serial port from my pc, and it doesn't send anything to the server.

Here is the device settings:

I have been looking in the logs to see why i'ts maybe not replying and I can see this:

What would cause this error?

What am I missing here?


 

ago by
Anyone had similar issues or anything I can try,

I have run out of options to try...

1 Answer

0 votes
ago by

Hello Zapnologica, 

Good day. Thank you for your question.

We require more information before we can provide you with a detailed answer to this. I would suggest that you raise a ticket on VIP Helpdesk or contact your distributor/Sales manager to assist you with this. If you don't have any contacts with our Sales managers, you may reach them at our official website https://teltonika-gps.com/ (please select "Vehicle Telematics" as your topic or you can send an e-mail with the description of your situation to info@teltonika.lt

Thank you for your understanding.

Kind regards.

ago by

Please advise as to what additional information you might need.

I have sent an email with the details to info@teltonika.lt