Ask a question

3515 questions

4005 answers

2989 comments

27713 members

Ask a question
0 votes
558 views
in Vehicle tracking by 1 flag
hi, im trying to the keep active the gprs connection always. This is because i need can send gprs commands to device anytime. Now when i send a gprs command when the vehicle is parked i get the error "No GPRS connection". I tried with Network ping timeout set to 10 but not work also i tried setting the Open Link Timeout to 259200 for try keep connection but not work. How i can do it with the minor data consumption?

PD. I have disabled Sleep mode.

Thanks in advance.

Greetings.

1 Answer

0 votes
by

Hello Victorhugo_lc,

Good day. Thank you for the question.

If you referring to having the best way to keep the GPRS connecting alive when vehicle is parked, then I suggest that you choose the sleep mode as Online Deep Sleep. It does not close the GPRS context if one was previously opened and you may set the Data Acquisition to a longer period while its parked to save more data. https://wiki.teltonika-gps.com/view/FMB120_Sleep_modes

However, in this case you have disabled the sleep mode and set the Open Link Timeout to max (259200) so there could be a chance this the connection has be closed by the server itself or due to other reason. We will need to analyze on your device logs to confirm this. 

My suggestion is that you capture the device logs and share with us via VIP Helpdesk, so we can share any files/updater should you require them in future since we do not share any files on community forum. If you do not have a VIP Helpdesk account, you can check with your Distributor/Sales manger to provide you the access. If you don't have any contacts with our Sale managers, please contact with them on our official website https://teltonika-gps.com/ and click on the "Contact Us" button. When you click, please fill the form and submit it. 

Note: as a topic, please choose "Vehicle telematics" or you can send an e-mail with description of your situation to info@teltonika.lt 

Appreciate your kind understanding.

Best regards.

by
Vivek,

As a server backend developer I would suggest you to put maximum 15 minutes inactivity timeout. This is due to to fact that in most Linux systems with load balancing mapping you are limited to 15 minutes of inactivity before port/address mapping of TCP connection is silently dropped. Such closure is not visible by the client(device) until it attempts to send some data which will result to peer dropped error.

To overcome this you may enabe both on server and client TCP KEEPALIVE with SO_KEEPALIVE socket option, but this will introduce some additional traffic which we are usually try to avid on GPRS data plans.

Also this may not be a big problem if your customer have direct server located on the edge (with public IP adreess and no load-balancers or firewalls between its and Internet). But for any modern or large installation this is not a case - most of them are protected by middleware firewall or load-balancer.

So my general recommendation will be to allow all maximum values possible on device configuration side to map to current standard maximum TCP socket timeout in Internet - 15 minutes. This will save a lot of headache for your and our common customers.

Best regards,
flespi team