FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE
Ask a question

3739 questions

4262 answers

3169 comments

41174 members

Ask a question
0 votes
436 views
in Vehicle tracking by

Hi guys,

I have a couple devices `FM3001` and i've set up the parameter `Total Odometer` with `High` or `Panic` priority on devices:


And `Trip \ Odometer` settings are the following:

One of devices sends wrong values for `Total Odometer`: it sends `Total Odometer` values from `0` to `1000` and then sends `-1` and counter is reset to `0` and starts increasing again. There are example of `Total Odometer` values from some set of payloads in database:


Here is the following examples of payload with wrong `Total Odometer` values:

Payload 1:

00000000000001250804000001709984f340015697ae6ee948754a003f00100e0000fa1109ef00f00050001505c80045011e022500fa0007b5000ab600074231fa180000430fbc4400093142a00110ffffffff00000001709981af50005697aa97e9487760003e01600e0000001008ef01f00150011504c80045011e02250007b5000ab60007423533180000430fbd4400093142a00110000000aa0000000170998404f8005697ae6ee948754a003f00100c0000f01008ef01f00050011505c80045011e02250007b5000ab60007423228180000430fbf4400093142a00110ffffffff000000017099840cc8005697ae6ee948754a003f00100e0000ef1008ef00f00050001505c80045011e02250007b5000ab60007423226180000430fbc4400093142a00110ffffffff000400004451

Payload 2:

000000000000016b0805000001709980c108005697deace9487d0a004700630e0010001008ef01f00150011503c80045011e02251007b5000eb60007423515180010430fbe4400093142a00110000002cf00000001709980c4f0005697e01be9487cc7004700640e000b001008ef01f00150011503c80045011e02251007b5000eb6000742348718000b430fbc4400093142a00110000002d400000001709980c8d8005697e104e9487ca6004700630e0006001008ef01f00150011503c80045011e02250407b5000eb6000742350f180006430fbe4400093142a00110000002d800000001709980ccc0005697e147e9487c74004700630e0000001008ef01f00150011503c80045011e02250407b5000ab600074234d5180000430fbc4400093142a00110000002da0000000170998122b0005697e2a5e9487c42004700650e0009001008ef01f00150011504c80045011e02250c07b5000ab600074235ac180009430fbd4400093142a00110ffffffff000500005a17

All other devices send correct data according to `Total Odometer` setting so there are no errors in my `parser` of data probably.
All configuration is the same on all devices.
One difference is maybe firmware version on devices.

Question: why can the device send wrong `Total Odometer` values?

Thanks!

1 Answer

0 votes
by

Hello Dim,

Thank you for your detail explanation. We appreciate it.

In this case, we recommend to contact with your Sales manager and inform about it. Then he will contact with our Support Engineers which will help you to solve this question.

If you don't have any contacts with our Sale managers, please contact with them on our official website https://teltonika-iot-group.com/

and click on "Contact Us" button. When you will click, please fill form and submit it.

Note: as topic, please choose "Vehicle telematics".

Best regards,

Teltonika Support

by
Hello support!

The issue was solved with firmware upgrading.

Thank you.